Ankündigung

#1 2017-12-07 20:34:46

Jan
Gast

Fehlermeldungen mit PHP7.2

Hallo,
seit dem Update auf php7.2 (Arch Linux) wirft der Aufruf von Piwigo folgende Meldungen (überall, sprich auf jeder Seite). Laut Adminportal habe ich die aktuelle Version.

Deprecated: Function create_function() is deprecated in /var/www/piwigo/include/functions.inc.php on line 2165

Deprecated: Function create_function() is deprecated in /var/www/piwigo/plugins/AdminTools/include/MultiView.class.php on line 41

Deprecated: Function create_function() is deprecated in /var/www/piwigo/include/functions.inc.php on line 2165

Deprecated: Function create_function() is deprecated in /var/www/piwigo/include/functions.inc.php on line 2165

Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /var/www/piwigo/include/template.class.php on line 293

Warning: Cannot modify header information - headers already sent by (output started at /var/www/piwigo/include/functions.inc.php:2165) in /var/www/piwigo/include/page_header.php on line 101

Wie kann ich die Meldungen loswerden?

Viele Grüße,
Jan

#2 2017-12-08 11:14:46

teekay
Mitglied
2016-05-04
116

Re: Fehlermeldungen mit PHP7.2

Hi,

installiere php70 aus dem AUR. Was anderes bleibt dir derzeit nicht übrig, da weder Piwigo noch ein ganzer Haufen anderer PHP apps mit 7.2 kompatibel sind.

Offline

#3 2018-06-20 13:08:50

JXN17317
Gast

Re: Fehlermeldungen mit PHP7.2

Wie schaut es denn aus mit einem Update, dass vollständige Kompatibilität zur aktuellen PHP 7.2 herstellt? Ist ja immerhin schon ein halbes Jahr wieder ins Land gezogen und die Version 2.9.3 war ja wohl noch nicht die Lösung. :)

Brett Fußzeile

Unterstützt von FluxBB

github twitter facebook google+ newsletter Spenden Piwigo.org © 2002-2018 · Kontakt