Ankündigung

#16 2018-03-25 20:08:55

Reto
Gast

Re: Hilfe, keine Bilder nur Ausrufungszeichen

Hab jetzt noch ein 19 MB grosses animated GIF hochgeladen. Auch das funktioniert ohne Probleme!
Warum dann die JPG nicht?

#17 2018-03-26 10:52:55

Ludwig
Mitglied
Neustadt
2017-04-08
127

Re: Hilfe, keine Bilder nur Ausrufungszeichen

@reto
Hab mir deine Seite mal angesehen - scheint doch so zu sein, dass Du einige Bilder hochladen kannst sogar gif - wie lädst Du die jpg etc. hoch ?

LG Ludwig

Offline

#18 2018-03-27 22:19:12

Reto
Gast

Re: Hilfe, keine Bilder nur Ausrufungszeichen

So hab jetzt ne Lösung gefunden. Es geht wirklich nur mit externem Imagemagick oder ihr stellt das graphics_library auf "gd" um in der config_default.inc.php.

Für alle mit Synologie Diskstation und DSM 6

Auf dem Webserververzeichnis (wo euer Piwigo ordner ist)  unter /include die Datei config_default.inc.php bearbeiten.
Wenn man Imagick auf der Diskstation installieren will muss an im Paket-Zentrum unter "Einstellungen" - "Paketquellen"  den Link "http://packages.synocommunity.com" hinzufügen.

Unter Punkt "Allgemein" muss die Vertrauensebene auf "Synology Inc und vertrtauenswürdige Herausgeber" oder "Jeder Herausgeber" stehen.

Unter "Beta" muss das Kästchen "Ja, ich möchte die Beta-Versionen sehen!" angekreuzt sein.
Nun findet man das Paket "ImageMagick" - Installiert es ;)

Danach die "config_default.inc.php" im Web Verzeichnis wo ihr eure Piwigo am laufen habt im Unterverzeichnis /include öffnen und wie unten die beiden Zeilen anpassen!

$conf['graphics_library'] = 'ext_imagick';
$conf['ext_imagick_dir'] =  '/usr/syno/bin';

Viel Spass ;)


// Library used for image resizing. Value could be 'auto', 'imagick',
// 'ext_imagick' or 'gd'. If value is 'auto', library will be chosen in this
// order. If chosen library is not available, another one will be picked up.
$conf['graphics_library'] = 'ext_imagick';

// If library used is external installation of ImageMagick ('ext_imagick'),
// you can define imagemagick directory.
$conf['ext_imagick_dir'] =  '/usr/syno/bin';

@Ludwig
Habe per FTP, direkt ins gallery Verzeichnis kopiert und mit der iPhone App habe ich es auch ausprobiert. Es ligt wirklich daran, dass Synology eine abgespeckte Version von ImageMagick für die Photo-Station verwendet und die aber für Piwigo nicht funktioniert.
Jetzt aber endlich ohne Probleme

Brett Fußzeile

Unterstützt von FluxBB

github twitter facebook google+ newsletter Spenden Piwigo.org © 2002-2018 · Kontakt