Ankündigung

#1 2018-05-24 22:00:42

Spectrum
Mitglied
2018-05-24
7

Anmeldung nicht möglich: Cookie-Fehler

Hallo zusammen,

seit dem Update auf 2.9.3 kann ich mich nicht mehr anmelden. Es kommt immer die Fehlermeldung "Cookies werden geblockt oder von Ihrem Browser nicht unterstützt. Sie müssen Cookies erlauben, um sich anzumelden."

Cookies sind bei mir nicht geblockt. Ich habe es mit drei Browsern auf zwei Systemen und mit zwei meiner eingerichteten Accounts versucht.

Möglicherweise im Zusammenhang stehen auch folgende Fehlermeldungen:

Strict Standards: date(): We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /homepages/19/d606369955/htdocs/piwigo/include/common.inc.php on line 141

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /homepages/19/d606369955/htdocs/piwigo/include/common.inc.php:141) in /homepages/19/d606369955/htdocs/piwigo/include/common.inc.php on line 156

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /homepages/19/d606369955/htdocs/piwigo/include/common.inc.php:141) in /homepages/19/d606369955/htdocs/piwigo/include/common.inc.php on line 156

Warning: Cannot modify header information - headers already sent by (output started at /homepages/19/d606369955/htdocs/piwigo/include/common.inc.php:141) in /homepages/19/d606369955/htdocs/piwigo/include/page_header.php on line 101

Was kann ich tun?

Gruß
Kai

Offline

#2 2018-08-01 22:28:31

Spectrum
Mitglied
2018-05-24
7

Re: Anmeldung nicht möglich: Cookie-Fehler

Ich versuche, diesen Beitrag nach oben zu spülen, denn das Problem besteht weiterhin.

Kai

Offline

#3 2018-08-01 23:32:58

drlecter
Mitglied
2016-03-17
76

Re: Anmeldung nicht möglich: Cookie-Fehler

Welche PHP Version hat dein Hoster?
Hast du testweise mal alle Plugins deaktiviert? Ich glaube man kann die auch evtl. aus dem Pluginverzeichnis verschieben. Müsste das selber aber noch einmal verifizieren.

Offline

#4 2018-08-02 21:39:17

Spectrum
Mitglied
2018-05-24
7

Re: Anmeldung nicht möglich: Cookie-Fehler

Hallo drlecter,

lieben Dank für die Antwort.

Es wird PHP 7.2 verwendet. Ich habe das Plugins-Verzeichnis testweise umbenannt, was am Fehlerbild (Cookie-Fehlermeldung) aber nichts ändert.

Gruß
Kai

Offline

#5 2018-08-02 23:06:34

drlecter
Mitglied
2016-03-17
76

Re: Anmeldung nicht möglich: Cookie-Fehler

Piwigo 2.9.3 hat Probleme mit PHP 7.2 (IMHO wird das nicht unterstützt).
Erst ab 2.9.4 funktioniert es mit php 7.2.

Offline

#6 2018-08-03 20:14:46

Spectrum
Mitglied
2018-05-24
7

Re: Anmeldung nicht möglich: Cookie-Fehler

Ich kann halt auf 2.9.4. nicht updaten, weil ich mich nicht einloggen kann.

Zumindest scheint es nicht alleine an der PHP 7.2 zu liegen, denn mit Downgrade auf 7.0 und 7.1 hatte ich es auch schon probiert.

Kann ich vielleicht auf 2.9.4. durch manuelles Austauschen von Dateien updaten?

Kai

Offline

#7 2018-08-04 11:54:49

drlecter
Mitglied
2016-03-17
76

Re: Anmeldung nicht möglich: Cookie-Fehler

Das sollte möglich sein. Den manuellen Updatepfad aus der Doku befolgen. Die DB sperren fällt ja weg bei dir.

Offline

#8 2018-08-04 22:09:11

Spectrum
Mitglied
2018-05-24
7

Re: Anmeldung nicht möglich: Cookie-Fehler

Ich hab's nach  folgender Anleitung gemacht:

https://de.piwigo.org/doc/doku.php?id=b … g:manuelle

Leider hat's nichts genützt. Die Fehlermeldung bleibt.

Offline

#9 2018-08-04 22:16:21

drlecter
Mitglied
2016-03-17
76

Re: Anmeldung nicht möglich: Cookie-Fehler

Was hast du für Themes installiert bzw. aktiv? Kannst du mal eine nackte Version zum testen parallel installieren?

Offline

#10 2018-08-04 22:46:50

Spectrum
Mitglied
2018-05-24
7

Re: Anmeldung nicht möglich: Cookie-Fehler

Ich hab an den Themes-Einstellungen nichts geändert oder etwas nachinstalliert.

Ich habe gerade in ein neues Verzeichnis ein zweites Piwigo installiert. Und, was soll ich sagen, es verhält sich genau so wie das erste.

Kai

Offline

#11 2018-08-04 23:16:18

drlecter
Mitglied
2016-03-17
76

Re: Anmeldung nicht möglich: Cookie-Fehler

Hm, so aus der Ferne muss ich da passen. Man könnte versuchen, die PHP Ausgaben zu erhöhen. Den Date Fehler könnte man mit den entsprechenden Eintrag in der php.ini beheben. Ich habe auch keine PHP Installation unter Windows am laufen (das ist ein paar Jahre her).

Offline

Brett Fußzeile

Unterstützt von FluxBB

github twitter facebook google+ newsletter Spenden Piwigo.org © 2002-2018 · Kontakt