Ankündigung

#1 2018-10-10 11:05:16

MikeFrizz
Mitglied
Berlin-Lankwitz
2018-10-10
3

Keine Verbindung zum mysql (mariadb) Server

Hallo,
ich bekomme bei der Installation die Fehlermeldung, das keine Verbindung zum Datenbankserver aufgebaut werden kann. Der Eintrag im Log sieht so aus:

[client 192.168.178.40:4990] PHP Warning:  mysqli::__construct(): (HY000/2002): Connection refused in /var/www/html/piwigo/include/dblayer/functions_mysqli.inc.php on line 67, referer: http://192.168.178.98/piwigo/install.php?language=de_DE
[Wed Oct 10 10:54:36.592475 2018] [:error] [pid 5438] [client 192.168.178.40:4990] PHP Warning:  mysqli::set_charset(): Couldn't fetch mysqli in /var/www/html/piwigo/include/dblayer/functions_mysqli.inc.php on line 103, referer: http://192.168.178.98/piwigo/install.php?language=de_DE

Noch einmal die Credentials für den Admin des Datenbankservers kontrolliert, doch die stimmen. Was kann die Ursache sein?
Vielen Dank für die Hilfe bereits jetzt.

MikeFrizz

Offline

#2 2018-10-10 12:07:41

drlecter
Mitglied
2016-03-17
82

Re: Keine Verbindung zum mysql (mariadb) Server

Darf auch der Benutzer auf die DB zugreifen? Bei der DB kann man einstellen von wo aus der Benutzer zugreifen darf (localhost, IP oder überall). Wenn piwigo und DB auf dem gleichen Server läuft, reicht idR. localhost bzw. 127.0.0.1. Dann muss aber auch bei der Installation von piwigo dies als DB Adresse angegeben werden.

Offline

#3 2018-10-10 14:31:20

MikeFrizz
Mitglied
Berlin-Lankwitz
2018-10-10
3

Re: Keine Verbindung zum mysql (mariadb) Server

Das muß ein ziemlicher Bug sein. Auf keinem meiner Server verbindet sich das Setup mit Mysql. Und der Datenbankserver läuft auf der selben Maschine. So etwas habe ich noch nicht erlebt. root als db Admin darf sich auf localhost anmelden. Nicht das jemand auf die Idee kommt, hier könnte der Hase im Pfeffer liegen.
Das ist etwas ätzend

Offline

#4 2018-10-10 14:51:49

MikeFrizz
Mitglied
Berlin-Lankwitz
2018-10-10
3

Re: Keine Verbindung zum mysql (mariadb) Server

Tja Leute,
Die Datenbanktabelle wird durch das Installationsskript nicht gefüllt weil diese nicht existiert. Das Skript findet keine vorhandene Tabelle und erzeugt den von mir geschilderten Fehler. Ein Bug im Skript. Zudem wird der User auch nicht nach dem Ort der zu speichernden Bildern gefragt. Ich hoffe, das ich diesen Nachteil mit einem symbolischen Link beheben kann.
Angelegt habe ich die Tabelle mit meinem webmin. Sollte aber auch natürlich mit phpmyadmin oder im Dialog mit Mysql bzw. MariaDB funktionieren.
Noch ein Nachteil ist, das das Skript, jedenfalls auf meinem Webordner, vollen, also 777er, Zugriff verlangt.
Michael

Beitrag geändert von MikeFrizz (2018-10-10 15:38:04)

Offline

#5 2018-10-10 16:48:00

drlecter
Mitglied
2016-03-17
82

Re: Keine Verbindung zum mysql (mariadb) Server

Ich habe piwigo (ich glaube es war 2.7) damals ohne Probleme installiert. Ich muss gestehen, ich weiss nicht ob ich damals kurzfristig einmal 777 dem Ordner zugewiesen habe. Ich glaube ich habe aber die manuelle Installation und nicht netinstall genommen.
Das ganze läuft bei mir als Subdomain in  einem eigenen Root mit php-fpm/suexec.
Wenn du als root Zugriff mittels phpmyadmin hast, dann schaue doch einmal nach, welche Rechte der Benutzer auf die DB hat. So sehen meine Rechte für die DB aus.
DBPIWIGO    localhost    datenbankspezifisch    ALL PRIVILEGES    Nein
bei der Installation gab ich localhost als Ziel an und das funktionierte ohne Probleme.
Probiere mal die Manuelle Installation.

Speicherort:
Piwigo arbeitet normalerweise mit virtuellen Alben. Wenn du Verzeichnisstrukturen hochladen willst (wie früher bei Gallery2/3) dann kannst du den Speicherort später im Adminpanel eintragen.

Offline

Brett Fußzeile

Unterstützt von FluxBB

github twitter facebook google+ newsletter Spenden Piwigo.org © 2002-2018 · Kontakt