Piwigo 2.1.4 Versionshinweise

Downloads Piwigo 2.1.4
Update von 2.1.x auf 2.1.4
Veröffentlicht am 30. Oktober, 2010 (2010-10-30)
Fokus Beseitigung von Fehlern und neue Sprachen
md5sum c7037097416affd55aed8fed2af024c7

Hinweis: Die Liste der grundlegenden Veränderungen wurde schon in den Piwigo 2.1.0 Versionshinweisen beschrieben. Diese Seite beschreibt nur die Änderungen zwischen den Versionen 2.1.3 und 2.1.4.

Sprachen

  • 0001871: Neue Sprache: Swedish (Svenska). Danke an Jonas
  • 0001921: Neue Sprache: Serbisch (Српски). Danke an Ћирилица1
  • 0001919: Neue Sprache: Hebräisch (עברית). Danke an Adirbiton
  • 0001889: Neue Sprache: Slovakisch (Slovensky). Danke an dodo
  • 0001890: Neue Sprache: Slovenisch (Slovenšcina). Danke an Klemen

Behobene Fehler

  • 0001852: [navigation] Nicht funktionierende HTML-umleitungen auf den Adminseiten
  • 0001974: [metadata] Generiere kein ungültiges Erzeugungsdatum von IPTC
  • 0001906: [batch management] Benutze die für eine Kategorie definierte Sortierreihenfolge für Bilder
  • 0001872: [notification] Falsche Gallerie URL in Abonnementnotifizierungs E-mails
  • 0001908: [security] Dateiname eines Bildes wird während des Uploads nicht geschützt
  • 0001973: [security] [comments.php] SQL Query Fehler (wird angezeigt), wenn die Kategorie ID nicht bekannt ist

Neue Features

  • 0001756: [API] [pwg.session.getStatus] gibt das Securitytoken zurück

Fehler in Bezug auf PostgreSQL/SQlite

  • 0001914: [database] Fehlender Tabellennahme

Aktualisierung

Empfohlene Methode: Folgen Sie der automatischen Upgradeprozedur.

Wenn Sie Piwigo 2.1.0, 2.1.1, 2.1.2 oder 2.1.3 verwenden, können Sie auch das 2.1.x_to_2.1.4.zip Archiv herunterladen, das nur neue oder veränderte Dateien enthält. Entpacken Sie die Datei in einen Ordner, und laden Sie ihn mit einem FTP-Client (am Besten mit FileZilla) auf ihren Webserver. Achten Sie darauf, dass Sie alle Dateien Ihrer bestehenden Piwigo 2.1.x Installation überschreiben. Ein Datenbankupgrade ist nicht erforderlich.

Wenn Sie eine ältere Version als 2.1.0 auf ihrem Webserver haben, benutzen Sie bitte nicht das automatische Upgrade. Benutzen Sie in diesem Fall bitte das manuelle Upgrade.

github twitter facebook google+ newsletter Spenden Piwigo.org © 2002-2018 · Kontakt