Ankündigung

Antwort schreiben

Schreiben Sie hier Ihren Beitrag

Click in the dark area of the image to send your post.

Zurück

Übersicht (Neuester Beitrag zuerst)

drlecter
2021-03-30 20:59:24

Die Config existiert nicht, ,weil du keine Anpassungen gemacht hast. Einfach eine Datei anlegen und die Optionen die man verändern möchte da eintragen. Somit überschreibt man die Default Einträge (normales Vorgehen bei vielen webbasierten Dingen). Somit werden die eigenen Einträge nicht überschrieben, wenn die Standard Config angepasst wird.

DerSchatten
2021-03-30 20:12:47

Eine local/config/config.inc.php gibt es bei mir nicht.
In dem local/config/ Verzeichnis befindet sich nur die index.php

Und wo genau ändere ich nun was in der config_default.inc.php ?

Wie gesagt, in den Apache Logs sind keine Einträge die auf einen Zugriffversuch oder sonstiges hindeuten was im Zusammenhang mit der Datenbank steht.

drlecter
2021-03-21 20:37:55

Die config_default.inc.php liegt unter include.
Änderungen macht man aber in local/config/config.inc.php
Man überschreibt halt immer die Option die man aus der default ändern will.
Du kannst aber das zuerst einmal in der default anpassen.
Was sagen die Apache logs?
Liegt das Verzeichnis auch unterhalb vom Apache Root?

DerSchatten
2021-03-21 16:09:27

wo genau?

drlecter
2021-03-21 14:21:35

Es sollte laufen. Du kannst einmal probieren den absoluten Pfad in der config fest einzutragen. Also eine eigene config erstellen und die Default werte überschreiben.
Andererseits solltest du doch beide Pakete parallel installieren können. Ich weiß aber nicht, wie sich der Apache verhält.

DerSchatten
2021-03-21 14:19:01

Gibt es ja, aber damit läuft wieder ein anderes Packet nicht. Ich bin deshalb auf 7.0 angewiesen.

drlecter
2021-03-21 14:16:04

Hm es gibt doch auch ein 7.2 Paket oder? müsste bei mir mal nachschauen.

DerSchatten
2021-03-21 14:04:37

Mit PHP 7.0

DerSchatten
2021-03-21 14:03:28

Nichts was auf einen Zugriffversuch hindeuten könnte.
Der letzte Eintrag ist vom 18.03

Ich verwende übrigens Apache 2.2 Sollte aber funktionieren, oder?

drlecter
2021-03-21 13:32:43

Dann läuft etwas bei der Erkennung schief. Steht das im Apache Log?

DerSchatten
2021-03-21 13:28:24

Manuelle Installation habe ich auch schon versucht.

an error occurred
Give write access (chmod 777) to "_data/" directory at the root of your Piwigo installation

Der ganze Ordner wo die Installationsdateien liegen hat 0777

drlecter
2021-03-21 13:09:08

Du könntest auf der Synology mal schauen ob im Apache log was steht. Ich vermute er wird versucht, in ein tmp Verzeichnis zu schreiben. Wenn du das Verzeichnis kennst, dann nimm die Manuelle Installation. Gerade der NetInstall kann Probleme machen.

DerSchatten
2021-03-21 13:06:02

Das Problem ist, es sind alle Rechte gesetzt auf dem Ordner: 0777
SSH ist aktiv auf Port 22

drlecter
2021-03-20 16:45:53

Auf dem Synology kannst du dich auch per ssh anmelden.
Es sind die Berechtigungen im Dateisystem gemeint.

Slim
2021-03-20 15:51:37

Hallo,

vielleicht hilft dir das weiter.

https://de.piwigo.org/forum/viewtopic.php?id=1069

Du loggst dich per FTP auf dem Server ein und kannst dann mit der rechten Maustaste auf den Ordner die Rechte vergeben. Ganz Einfach :)


Slim

Brett Fußzeile

Unterstützt von FluxBB

github twitter newsletter Spenden Piwigo.org © 2002-2022 · Kontakt