Ankündigung

#1 2016-06-05 17:43:16

Nils
Gast

PHP 5.3 auf PHP 5.6

Hello @ all,
gleich vorweg, ich bin nicht so System bewandert, welches unter Piwigo liegt und finde das System wirklich toll, für jemanden der nicht in der tiefe das System beherrschen möchte...

Nun muss ich aber leider doch eine Frage stellen und hoffe dass ich hier richtig bin.

Ich muss leider meine PHP Version upgraden und habe Angst, dass Piwigo dann nicht mehr laufen wird.
Also ich muss von PHP 5.3 auf PHP 5.6 Upgrade. An sich sollte dass ja kein Problem sein, da die 5.6 ja abwärts kompatibel sein sollte. Aber man weiß ja nie, insbesondere, weil auf der englisch sprachigen Piwigo Forumseiten, der eine oder andere von Problemen berichtet hat, das waren aber berichte aus dem letzten Jahr.

Nun bin ich mir unsicher, wie der Stand der Dinge ist. Leider brauche ich die 5.6 ansonsten würde ich nicht upgraden :-)

Wie ist eure Erfahrung mit solch einem Upgrade (-sprung) ?
Muss ich mit Problemen rechnen?
Wenn ja, wie kann ich mich darauf vorbereiten?  Bitte jetzt nicht schreiben "Backup machen"... Ach nee ;-)))

Wäre übere jede Information diesbezüglich dankbar :-)

Piwigo 2.8.1 Server-Umgebung
Betriebssystem: Linux PHP: 5.3.10-1ubuntu3.23  [2016-06-05 17:03:19]
MySQL: 5.5.49-0 ubuntu0.12.04.1 [2016-06-05 17:03:19]
Grafikbibliothek: External ImageMagick 6.6.9-7
Datenbank
3918 Fotos (erstes Foto am Mittwoch 10 Juni 2015 hinzugefügt)
118 Alben enthalten, davon 0 physisch und 118 virtuell (4491 Verknüpfungen)

#2 2016-06-07 00:26:23

WuppiGER
Mitglied
Germany
2016-05-31
22

Re: PHP 5.3 auf PHP 5.6

Piwigo-Version

        Piwigo 2.8.1

Server-Umgebung

        Betriebssystem: Linux
        PHP: 5.6.21-nmm1 (Info anzeigen) [2016-06-07 00:24:31]
        MySQL: 5.5.49-nmm1-log [2016-06-07 00:24:31]
        Grafikbibliothek: ImageMagick 6.6.9-7

Gegen 5.6 spricht nichts. Hab auch das ein oder andere Plugins laufen - kein Ding. Wobei ich mir eher Probleme bei alten Plugins vorstellen könnte?

Offline

#3 2016-06-11 19:46:01

Slim
Mitglied
2013-03-09
230

Re: PHP 5.3 auf PHP 5.6

Hallo,

also ich verwende Piwigo unter PHP 7.0.6 und habe keine Probleme.

Übrigens die Plugins werden immer bei neuem Release auch angepasst,
so das es hier selten ärger gibt.

Es gibt allerdings auch Plugins die nicht mehr benötigt werden und da macht
dann eine Anpassung keine sinn mehr.

slim

Beitrag geändert von Slim (2016-06-12 17:47:36)

Offline

Brett Fußzeile

Unterstützt von FluxBB

github twitter newsletter Spenden Piwigo.org © 2002-2020 · Kontakt