Ankündigung

#1 2020-01-18 09:32:30

lr_pw
Mitglied
2020-01-18
5

Datenbanktabellen angelegt, aber Piwigo startet nicht

Hallo,
Webspace bei Hosteurope (PHP 7.2)
Manuell Installation
Die Datenbank (33 Tabellen) wird angelegt, aber Piwigo startet nicht, Ich lande immer wieder auf der Installationsseite.

Weitere Installationen auf den Webspace: Wordpress, Nextcloud und Koken

Sind alle Tabellen angelegt?
Zugriffsrechte?

Danke für Hilfe
Lore

Offline

#2 2020-01-18 11:26:29

drlecter
Mitglied
2016-03-17
295

Re: Datenbanktabellen angelegt, aber Piwigo startet nicht

Nutzt du netinstall oder hast du alles hochgeladen und dann die installationsroutine gestartet?

Offline

#3 2020-01-18 12:20:39

lr_pw
Mitglied
2020-01-18
5

Re: Datenbanktabellen angelegt, aber Piwigo startet nicht

Manuelle Installation, also hochgeladen und dann die Konfiguration gestartet. Daraufhin wurden die Tabellen in der Datenbank angelegt.

Offline

#4 2020-01-18 12:27:31

drlecter
Mitglied
2016-03-17
295

Re: Datenbanktabellen angelegt, aber Piwigo startet nicht

Hm, ich hab piwigo vor langem manuell installiert.
Nachdem man die Daten eingegeben hat, hab bei mir die Meldung, Installation abgeschlossen. Ich schaue mal bei meiner Instatallation nach.
Andere Frage: Nutzt du noch koken? Ich hatte mir das auch mal angeschaut aber die Entwicklung hat sich wohl erledigt.

Offline

#5 2020-01-18 12:45:12

lr_pw
Mitglied
2020-01-18
5

Re: Datenbanktabellen angelegt, aber Piwigo startet nicht

Koken in der aktuellen Version läuft bei Hosteurope nicht mehr, da aus Sicherheitsgründen irgendwas (müsste ich nachschauen) nicht mehr akzeptiert wird. Damit können zwar die alten Sammlungen weiterhin angeschaut werden, aber Admin-Seite geht nich tmehr :-(
Koken war toll!

http://dd-learn.de/kokenlr/

Lore

Offline

#6 2020-01-18 13:00:45

drlecter
Mitglied
2016-03-17
295

Re: Datenbanktabellen angelegt, aber Piwigo startet nicht

Koken wird ja auch nicht mehr weiterentwickelt.
Ich habe das gerade auf meinen Testserver installiert. Alle Dateien hochgeladen und die URL aufgerufen.
Nachdem ich die DB und admin Infos eingetragen habe (also auf der Seite: http://piwigo.org/screenshots/piwigo_in … 3-a_en.png) kam die Abschlussmeldung wie hier: http://piwigo.org/screenshots/piwigo_in … -b_en.png.
Ich musste aber bevor ich die Installation starte die generische index.html (es wird immer eine Standardseite erstellt) löschen.
Ich vermute, das evtl. die Einstellung für die DB nicht gespeichert wird. Das kann ein Berechtigungsproblem sein. Wenn diese Datei nicht existiert, dann wird man automatisch auf die Installation umgeleitet.
Die Datei liegt unter: local/config (vom Verzeichnis ausgehend, wo du alles hochgeladen hast) und heisst: database.inc.php
Der Inhalt ist kurz:
<?php
$conf['dblayer'] = 'mysqli';
$conf['db_base'] = 'DATENBANKNAME';
$conf['db_user'] = 'USER';
$conf['db_password'] = 'PASSWORT';
$conf['db_host'] = 'DATENBANK_Host (idR. localhost)';

$prefixeTable = 'piwigo_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

?>
Schaue einmal ob die Datei existiert.
Wenn nicht, kannst du kurzfristig die Berechtigungen anpassen. Ich habe das ganze bei mir restriktiver und habe leider keine Erfahrung mti HE.

Beitrag geändert von drlecter (2020-01-18 13:01:39)

Offline

#7 2020-01-18 14:56:40

lr_pw
Mitglied
2020-01-18
5

Re: Datenbanktabellen angelegt, aber Piwigo startet nicht

Danke - die Datei existiert nur lokal. Versuche die Berechtigungen anzupassen.

Offline

#8 2020-01-18 15:51:44

lr_pw
Mitglied
2020-01-18
5

Re: Datenbanktabellen angelegt, aber Piwigo startet nicht

Super, es war die fehlende Datei.
Wird sogar nach der Installation angezeigt - Lesen müsste frau können.

Offline

#9 2020-01-18 16:51:03

drlecter
Mitglied
2016-03-17
295

Re: Datenbanktabellen angelegt, aber Piwigo startet nicht

Kaum macht man es richtig, schon funktioniert es *duck* :D
Dann viel Spass damit.
Ja Koken gefiel mir damals auch (ich suchte eine Alternative für Gallery2/Gallery3). Aber die Resonanz bei denen lies halt zu wünschn übrig. Die Supportseite funktiniert wohl ganrnicht mehr. Bei FB kommt auch nichts mehr. Ich denke die neuen Besitzer haben nach der Übernahme den leisen Tod beschlossen.

Offline

Brett Fußzeile

Unterstützt von FluxBB

github twitter facebook google+ newsletter Spenden Piwigo.org © 2002-2020 · Kontakt