Ankündigung

#1 2020-06-02 18:36:42

Thomas
Gast

upload Problem / bricht ab

Hallo,

ich nutze piwigo schon sehr lange ohne Probleme.
Seit kurzem habe ich Probleme mit dem Foto Uplaod über das Webformular, ohne dass ich eine Ursache ausmachen kann:

- das Webformular bricht von selbst ab und springt zum Set Edit (alle Bilder in der Warteschlange werden nicht mehr hochgeladen geladen, es erscheint kurz ein gelbes Dreieck)

- Bilder sind manchmal beschädigt (ein Teil des Bildes ist grau)

- das Webformular steigt ganz aus (Warteliste verschwindet, Seite bleibt hängen)

Fehlermeldungen werden keine gezeigt.

Ich nutze die neuste Piwigo Version 2.10.2 auf einem Webdienst.

Vielen Dank für Tipps.

Thomas

#2 2020-06-02 20:38:31

drlecter
Piwigo Team Moderators
2016-03-17
717

Re: upload Problem / bricht ab

Hast du bei deinem Webdienst (ich denke ein Hoster wie Strato/1&1/Netcup usw.) ein Webinterface wo du dir auch Logfiles anzeigen lassen kannst? Funktionieren einzelne Bilder? Es kann sein, das es Limits gibt (vielleicht nach einem Update vom Provider aus) die nicht angepasst wurden.

Offline

#3 2020-06-02 21:04:19

Thomas
Gast

Re: upload Problem / bricht ab

Danke für die Antwort.

Log Files kann ich leider nicht lesen, dafür fand ich jedoch die Limits
https://domainname.shop/faq?id=281
und die Settings der ModSecurity rules:
https://domainname.shop/faq?id=257

"File uploads are also limited by the ModSecurity rules. These cannot be overridden."

Einzelne Files gehen ohne Probleme.
Eine komplette Neuinstallation von Piwigo hat dasselbe Problem.

Falls es an den ModSecurity rules liegt, die ich nicht ändern kann, habe ich da eine Chance das Problem zu lösen? Oder bleibt dann nur noch die FTP Variante?

Vielen Dank für die Rückmeldung.

Thomas

#4 2020-06-02 21:34:04

drlecter
Piwigo Team Moderators
2016-03-17
717

Re: upload Problem / bricht ab

Wenn man SecUploadFileLimit sich anschaut, steht das auf 10. Also versuche das mal mit 10 Dateien. Alternativ halt FTP bzw. müsste man das auch ggf. über die API oder so machen können. Für Lightroom gab es auch ein (kostenpflichtiges) Plugin.

Offline

#5 2020-06-03 19:33:57

Thomas
Gast

Re: upload Problem / bricht ab

Vielen Dank für den Hinweis.

Die Anzahl (SecUploadFileLimit 10 ) scheint es jedoch nicht zu sein.
Ich kann ohne Problem über 10 Files hochladen, wenn ich wohl unter einer bestimmten Speichergrenze bleibe.

Es scheint an der folgenden maximalen Grenze zu liegen:

# Max size of incoming data
# 128 MiB
SecRequestBodyLimit

Da meine Bilddatenbank mit Files in Originalgröße arbeitet, erreiche ich diesen Wert von 128 MB schnell.

Auffällig ist, dass ich irgendwie das Webformular zurücksetzen muss, erst dann schaffe ich es, weitere Bilder hochzuladen. Welche Aktion das Formular wirklich zurücksetzt und den Speicher freigibt, bin ich mir nicht ganz sicher.


Thomas

Brett Fußzeile

Unterstützt von FluxBB

github twitter newsletter Spenden Piwigo.org © 2002-2021 · Kontakt