Ankündigung

#1 2019-09-01 00:36:24

Dario
Gast

Nichts lässt sich anklicken

Hallo zusammen,

ich wollte Piwigo gerade installieren und mal sehen, ob es kann was ich suche. Leider lässt sich außer den Menü-Punkten nicht ändern.
Zum Beispiel Album von Öffentlich auf Privat. Man kann es einfach nicht anklicken. Das betrifft alle Einstellungen, die man vornehmen könnte.


Was mache ich falsch?

Danke und Viele Grüße
Dario

#2 2019-09-11 20:45:17

Nico2
Gast

Re: Nichts lässt sich anklicken

Habe das gleiche Problem. Alles scheint zu laufen, wenn ich ein neues Album erstellen möchte also auf den Link klicke passiert einfach nichts. Und Hilfe scheint hier auch nicht in Sicht ....

#3 2019-09-11 21:56:22

drlecter
Mitglied
2016-03-17
222

Re: Nichts lässt sich anklicken

Das deutschsprachige User Forum ist halt nicht so gut frequentiert. Ist halt ein reines Userforum.
Ohne mehr Infos wird die Fehleranalyse schwierig.
Wo installiert? Eigener Server? Webhosting? Welcher Provider? Welche Version von piwigo? Welche PHP Version? Welche MySQL? Welcher Browser? Browser Plugins? Anderen Bowser ohne Addblocker usw. getestet?

Offline

#4 2019-09-12 10:07:27

Nico2
Gast

Re: Nichts lässt sich anklicken

Hoster Alfahosting
PHP 7.0 aber auch schon mit 7.3 getestet
Version findei ch nicht habe über den Netinstaller die neuste installiert
Getestet mit Firefox und Microsoft Edge

Ich habe eben mal die Tour nach Neuinstallation gestartet - da konnte ich Alben anlegen und Bilder hochladen. Nach der Tour sind die Alben und Bilder auch da aber:
- kann keine neuen Fotos hochladen, da hier kein Album angezeigt wird. Nur der Link neues Album erstellen. Klicke ich drauf, passiert wieder nichts.
Gehe ich auf Alben sehe ich die erstellen Alben aus der Tour. Will ich neue erstellen - wieder keine Reaktion.

In einem anderen Forum habe ich gelesen man sollte mal ein paar Serverwerte ändern (Also Speicher, excecution time usw.) habei ch alles auf maximum gestellt im Rahmen dessen was der Hoster zulässt. Keine Änderung.

#5 2019-09-12 10:09:44

Nico2
Gast

Re: Nichts lässt sich anklicken

Wenn ich richtig gesehen habe Piwigo 2.9

eben noch ein Test: Wenn ich nachträglich nochmal die Tour zum Thema Alben starte ... kann ich dort wieder Alben erstellen. Beende ich die Tour und gehe auf Alben .... nichts.

#6 2019-09-12 16:55:59

drlecter
Mitglied
2016-03-17
222

Re: Nichts lässt sich anklicken

Nutzt dein Anbieter php-fpm/suexec? Wie sind die Dateireichte?
Ich glaube netinstall ist verbuggt. Ich hatte das damals (2.7 oder so) "von Hand" installiert und seitdem nur noch mit updates versehen.
Kommst du an deine Webserverlogs ran?

Offline

#7 2019-09-12 17:27:00

Nico2
Gast

Re: Nichts lässt sich anklicken

Wie finde ich das denn heraus?
Die Logs habe ich aktiviert heute, ja diese kann ich einsehen.

#8 2019-09-12 17:32:09

Nico2
Gast

Re: Nichts lässt sich anklicken

Ich habe eben mal in das log-file (error_log) gesehen (einfach nur aneinandergereihter Text, habe noch nichts ausgewertet), aber in jeder Meldung die ich gelesen habe steht


[Thu Sep 12 17:24:56.731449 2019] [core:crit] [pid 44303:tid 140321471915776] (13)Permission denied: [client xx.xxx.xxx.xx:63909] AH00529: /var/www/xxx/html/xxx/themes/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/var/www/xxx/html/xxx/themes/' is executable
Eine htaccess Datei gibt es für die Domain nicht.

#9 2019-09-12 17:50:56

Nico2
Gast

Re: Nichts lässt sich anklicken

Habe gerade mal dem Ordner Themes alle Berechtigungen per FTP gegeben (also 777) und damit läuft es auf einmal.... aber das sollte auch keine Dauerlösung sein oder? Welche Berechtigungen sind denn hier nötig um Sicherheit + Funktion zu wahren?

#10 2019-09-12 19:47:06

drlecter
Mitglied
2016-03-17
222

Re: Nichts lässt sich anklicken

Ich denke 755 sollte reichen. Es kann auch sein, dass der Benutzer richtig gesetzt werden muss.
Hast du einen ssh Zugang?

Offline

#11 2019-09-12 20:49:30

Nico2
Gast

Re: Nichts lässt sich anklicken

Ja, SSH habe ich

#12 2019-09-12 21:56:27

drlecter
Mitglied
2016-03-17
222

Re: Nichts lässt sich anklicken

Du kannst dich dann einmal anmelden und mit ls -al dir die Benutzerrechte des Webverzechnisses anzeigen lassen. Da siehst du dann deinen Webbenutzer und die Gruppe.
Das Piwigo Verzeichnis sollte die gleichen Einstellungen haben. (normalerweise passt das auch bei einem Upload). Wenn das mit den Rechten 755 funktioniert, ist aber alles gut.

Offline

Brett Fußzeile

Unterstützt von FluxBB

github twitter facebook google+ newsletter Spenden Piwigo.org © 2002-2019 · Kontakt