Ankündigung

#1 2021-02-15 21:53:23

HarrySch.
Mitglied
2019-01-07
20

Piwigo startet nicht mehr ...

Bekomme seit heute diese Fehlermeldungen:


Warning: mysqli::__construct(): (HY000/1045): Access denied for user 'Harald_Schuster'@'localhost' (using password: YES) in /var/www/vhosts/euro-picture.de/httpdocs/piwigo/include/dblayer/functions_mysqli.inc.php on line 52

Warning: my_error(): Couldn't fetch mysqli in /var/www/vhosts/euro-picture.de/httpdocs/piwigo/include/dblayer/functions_mysqli.inc.php on line 856

Warning: my_error(): Couldn't fetch mysqli in /var/www/vhosts/euro-picture.de/httpdocs/piwigo/include/dblayer/functions_mysqli.inc.php on line 856
Piwigo encountered a non recoverable error

[mysql error ]
Can't connect to server

#1    my_error /var/www/vhosts/euro-picture.de/httpdocs/piwigo/include/common.inc.php(113)
#2    include_once /var/www/vhosts/euro-picture.de/httpdocs/piwigo/index.php(11)

Woran könnte es liegen ?

Offline

#2 2021-02-15 22:48:17

drlecter
Piwigo Team Moderators
2016-03-17
659

Re: Piwigo startet nicht mehr ...

Du hast keine Verbindung zur Datenbank. Hat sich das Passwort geändert?

Offline

#3 2021-02-16 09:25:42

HarrySch.
Mitglied
2019-01-07
20

Re: Piwigo startet nicht mehr ...

Nicht dass ich wüsste, kann man das Passwort manuell irgendwo ändern?

Offline

#4 2021-02-16 11:54:48

drlecter
Piwigo Team Moderators
2016-03-17
659

Re: Piwigo startet nicht mehr ...

Das Passwort steht in der Datei:
local/config# vim database.inc.php
Du kannst denke ich mal bei deinem Provider ein neues Passwort für die Datenbank vergeben und dies dann eintragen.

Offline

#5 2021-02-17 20:43:58

HarrySch.
Mitglied
2019-01-07
20

Re: Piwigo startet nicht mehr ...

Habe jetzt mal alles gelöscht auch die DB, nun läßt es sich gar nicht mehr Neu installieren.
piwigo-netinstall.php geht noch dannach bleibt der Bildschirm weiss ....

Bin am verzweifeln

Offline

#6 2021-02-17 21:06:44

Slim
Piwigo Team Moderators
2013-03-09
482

Re: Piwigo startet nicht mehr ...

HarrySch. schrieb:

Bekomme seit heute diese Fehlermeldungen:

[mysql error ]
Can't connect to server

#1    my_error /var/www/vhosts/euro-picture.de/httpdocs/piwigo/include/common.inc.php(113)
#2    include_once /var/www/vhosts/euro-picture.de/httpdocs/piwigo/index.php(11)

Woran könnte es liegen ?

Hallo,

du möchtes gerne Hilfe hier im Forum. Aber Du bist nicht bereit Informationen zu liefern, wie und warum der Fehler entstanden ist. Irgendwas must Du ja gemacht haben wobei die Fehlermeldung entstanden sein könnte oder ist. Diese Infos wären zur Hilfestellung vom vorteil und sehr Hilfreich gewesen.

HarrySch. schrieb:

Habe jetzt mal alles gelöscht auch die DB, nun läßt es sich gar nicht mehr Neu installieren.
piwigo-netinstall.php geht noch dannach bleibt der Bildschirm weiss ....

Bin am verzweifeln

Und dann alles löschen ist so keine Lösung. Ohne weitreichende Information von Deiner seite wird Dir wohl keiner richtig helfen können.

Eine Glaskugel haben wir leider nicht.

Dir wird wahrscheinlich nur eine neue Installation weiterhelfen.

Slim

Offline

#7 2021-02-17 22:47:49

HarrySch.
Mitglied
2019-01-07
20

Re: Piwigo startet nicht mehr ...

Habe ja eine Neuinstalation versuch aber das funktioniert nicht ...

www.euro-picture.de war meine Fotoseite, seit dem neuenUpdate hatte ich probleme

Offline

#8 2021-02-18 07:20:12

foto-momente
Mitglied
Wien, Österreich
2014-05-12
80

Re: Piwigo startet nicht mehr ...

Guten Morgen Harald,

ich bin jetzt nicht der Piwigo Spezialist, habe aber Erfahrung mit anderen Webanwendungen.
Was mir auffällt, dass die Login Fehlermeldung für den User  'Harald_Schuster'@'localhost' ausgegeben wird, hast du vielleicht noch die Konfiguration einer lokalen Testinstallation und schon auf einen Server?

Grüße aus Wien,
Thomas

Offline

#9 2021-02-18 13:52:45

drlecter
Piwigo Team Moderators
2016-03-17
659

Re: Piwigo startet nicht mehr ...

Vorgehen wenn man das ganze bereinigen möchte:
Die Datenbank leeren (hier muss man Vorsicht walten lassen)
Das Verzeichnis wo piwigo installiert ist/war leeren
Danach kann man der manuellen Installation folgen. Es gibt Hoster, bei denen die automatische Installation Probleme macht
https://de.piwigo.org/anleitung/installation/manuellle

Offline

#10 2021-02-18 14:06:06

Slim
Piwigo Team Moderators
2013-03-09
482

Re: Piwigo startet nicht mehr ...

foto-momente schrieb:

Was mir auffällt, dass die Login Fehlermeldung für den User  'Harald_Schuster'@'localhost' ausgegeben wird, hast du vielleicht noch die Konfiguration einer lokalen Testinstallation und schon auf einen Server?

Grüße aus Wien,
Thomas

Guten Tag Thomas,

localhost wird von vielen als Datenbank Server benutzt. Strato und einige andere verwenden eigende Namen. Strato hat diesen Namen: rdbms.strato.de.

Es hat also nichts mit einer Localen Einrichtung zu tun.

Grüße
Norbert


EDIT: Schaut Euch mal den Link von HarrySch an. Sollen wir das Einrichten oder was macht er da!?!?

EDIT: Wie soll man einen Menschen helfen der selber nicht weiss was er da macht.

Offline

#11 2021-02-18 22:14:44

HarrySch.
Mitglied
2019-01-07
20

Re: Piwigo startet nicht mehr ...

PIWIGO läuft wieder .....

Offline

#12 2021-02-19 06:55:39

foto-momente
Mitglied
Wien, Österreich
2014-05-12
80

Re: Piwigo startet nicht mehr ...

HarrySch. schrieb:

PIWIGO läuft wieder .....

Guten Morgen,
kannst du uns bitte mitteilen woran es lag? Kann anderen Usern von Nutzen sein.

Danke und Grüße aus Wien,
Thomas

Offline

#13 2021-02-20 12:36:33

HarrySch.
Mitglied
2019-01-07
20

Re: Piwigo startet nicht mehr ...

Sicherung der Datenbank durchgeführt danach meine Galleriern gesicht und alles gelöscht und neu aufgespielt, bis auf die Videos läuft alles wieder!

Gruß
Harry

Offline

Brett Fußzeile

Unterstützt von FluxBB

github twitter newsletter Spenden Piwigo.org © 2002-2021 · Kontakt