Ankündigung

#16 2020-08-31 22:23:32

Hermann Groeneveld
Mitglied
2019-04-01
4

Re: Bilder werden plötzlich nicht mehr generiert

Jetzt funktioniert es! Hab nochmal neu hochgeladen – alles gut.

Danke für Deine Geduld.
Hermann

Offline

#17 2020-09-01 15:04:39

drlecter
Piwigo Team Moderators
2016-03-17
618

Re: Bilder werden plötzlich nicht mehr generiert

Beim hochladen werden die Bildergrößen neu berechnet. Scheinbar wurde bei dir was an IMagick geändert und somit wurde es nicht mehr benutzt.

Offline

#18 2021-01-10 21:28:58

spreewaelder
Mitglied
2021-01-10
2

Re: Bilder werden plötzlich nicht mehr generiert

Hallo Zusammen,

ich habe "vermutlich" das gleiche Problem wie meine Vorredner. Aktuell habe ich Piwigo in einer VM testweise installiert und dort die ersten Bilder synchronisiert. Leider sehe ich die Bilder genau einmal und dann nie wieder. Statt dessen bekomme ich nur weise Felder mit dem Dateinamen angezeigt.

Meine Daten sind:

    Piwigo 2.10.2
    Betriebssystem: Linux
    PHP: 7.4.3
    MySQL: 5.5.5-10.3.25-MariaDB-0ubuntu0.20.04.1
    Grafikbibliothek: ImageMagick 6.9.10-23

Ebenfalls habe ich geprüft, ob die benötigt die php-Erweiterung installiert wurde (php -i | grep imagick). Folgendes wurde mir ausgegeben:

  /etc/php/7.4/cli/conf.d/20-imagick.ini,
  imagick
  imagick module => enabled
  imagick module version => 3.4.4
  imagick classes => Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
  imagick.locale_fix => 0 => 0
  imagick.progress_monitor => 0 => 0
  imagick.skip_version_check => 1 => 1

Bei der Installation habe ich an dieser Anleitung orientiert:

https://howto.wared.fr/installation-piw … db-ubuntu/

Könnt Ihr mir bitte weiterhelfen.

Vielen Dank und Gruß,

Michael

Offline

#19 2021-01-10 21:49:07

drlecter
Piwigo Team Moderators
2016-03-17
618

Re: Bilder werden plötzlich nicht mehr generiert

Wie sieht es mit den Dateiberechtigungen aus? steht etwas in den Logs? Wenn da keine Bilder angezeigt werden, werden diese vielleicht nicht gefunden.

Offline

#20 2021-05-01 14:59:55

spreewaelder
Mitglied
2021-01-10
2

Re: Bilder werden plötzlich nicht mehr generiert

Hallo Zusammen,

Entschuldigung für die späte Rückmeldung. Um es kurz zumachen, war der Fehler in der nginx config und zwar hier:

# prevent direct acces to uploaded images, derivates and logs
    location ~ ^/(_data/(i|logs)|upload)/ {
        allow                      all;
    }

Anstatt "allow hatte ich deny. Jetzt funktioniert es wieder :). Hier zeigt sich wieder, dass man einen Plan haben sollte, was man tut :).

Vielen Dank und Gruß,

Michael

Offline

Brett Fußzeile

Unterstützt von FluxBB

github twitter newsletter Spenden Piwigo.org © 2002-2021 · Kontakt