Ankündigung

#1 2022-06-08 12:06:29

specialist383
Mitglied
2021-02-11
2

PHP-Version und viel "deprecated"

Nach einem Absturz musste ich meinen Server neu auf Ubuntu22 LTS aufsetzen, nun mit php8.1.2.
Nach einem erfolgreichen Versuch mit piwigo vor ein paar Jahren wollte ich jetzt auf dem neuen System damit eine aktuelle Gallerie mit Piwigo 12 einrichten.
Irgendwie ging es ja schon, aber ...
- beim Installationsbild kamen eine Menge Warnungen und eine fatal message (mehrzeilig)
- der Zugang funktionierte trotzdem schon,
- ich konnte auch ein Album anlegen, aber ....
auf jeder Seite ist mindestens 5-6 mal "der Befehle .... is deprecated in line ...." oder "missing index in array ... " oder so etwas. Da läuft etwas schief.
ein Hochladen von Fotos ist mit der leeren Web-Seite nicht möglich.

Meine Frage: vertragen sich Piwigo 12 und php8.1 (noch) nicht? Fehlt irgendetwas bei meiner Installation? gd, Imagick sind da, mysql funktioniert anscheinend auch, woran kann es liegen ?
"deprecated" bedeutet doch normalerweise, dass dieser Befehl mit der aktuellen php-Version nicht mehr abgearbeitet/ausgeführt wird. Einen 'Fehler' könnte man ja noch suchen und fixen, aber reihenweise geht das nicht. Wäre eine Parallelinstallation von php7.4 eine Lösung?

Offline

#2 2022-06-12 17:43:24

drlecter
Piwigo Team Moderators
2016-03-17
860

Re: PHP-Version und viel "deprecated"

Mit PHP8 gibt es wohl noch Probleme. Die Entwickler sind im engl. Forum unterwegs. Da gab es auch mal einen Stand zu php8.

Offline

Brett Fußzeile

Unterstützt von FluxBB

github twitter newsletter Spenden Piwigo.org © 2002-2022 · Kontakt